Vulnerability · Published Nov 29, 2024 · Assigned by GitHub_M

CVE-2024-53983Server-side request forgery in Backstage Scaffolder plugin

Medium 5.4

In plain English

A medium-severity server-side request forgery in backstage from backstage. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.4%top 68.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The Backstage Scaffolder plugin Houses types and utilities for building scaffolder-related modules. A vulnerability is identified in Backstage Scaffolder template functionality where Server-Side Template Injection (SSTI) can be exploited to perform Git config injection. The vulnerability allows an attacker to capture privileged git tokens used by the Backstage Scaffolder plugin. With these tokens, unauthorized access to sensitive resources in git can be achieved. The impact is considered medium severity as the Backstage Threat Model recommends restricting access to adding and editing templates in the Backstage Catalog plugin. The issue has been resolved in versions `v0.4.12`, `v0.5.1` and `v0.6.1` of the `@backstage/plugin-scaffolder-node` package. Users are encouraged to upgrade to this version to mitigate the vulnerability. Users are advised to upgrade. Users unable to upgrade may ensure that templates do not change git config.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@backstage/plugin-scaffolder-node0.4.12GHSA-qmc2-jpr5-7rg9
npm@backstage/plugin-scaffolder-node0.5.1GHSA-qmc2-jpr5-7rg9
npm@backstage/plugin-scaffolder-node0.6.1GHSA-qmc2-jpr5-7rg9

Affected products (as reported)

VendorProductVersions
backstage backstage < 0.4.12= 0.5.0= 0.6.0

Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:N/A:N

References