Vulnerability · Published Jan 23, 2025 · Assigned by apache

CVE-2024-53299Apache Wicket: An attacker can intentionally trigger a memory leak

Medium 6.5

In plain English

A medium-severity uncontrolled resource consumption in Apache Wicket from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.5% (higher than 74% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)1.5%top 25.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The request handling in the core in Apache Wicket 7.0.0 on any platform allows an attacker to create a DOS via multiple requests to server resources. Users are recommended to upgrade to versions 9.19.0 or 10.3.0, which fixes this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.wicket:wicket-core8.17.0GHSA-9cxr-76pm-j3wf
Mavenorg.apache.wicket:wicket-core10.3.0GHSA-9cxr-76pm-j3wf
Mavenorg.apache.wicket:wicket-core9.19.0GHSA-9cxr-76pm-j3wf

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Wicket 7.0.0 – through 7.18.*8.0.0-M1 – through 8.16.*9.0.0-M1 – through 9.18.*10.0.0-M1 – through 10.2.*

Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

References