Vulnerability · Published Nov 21, 2024 · Assigned by GitHub_M

CVE-2024-52797Searching Opencast may cause a denial of service

Medium 6.5

In plain English

A medium-severity resource allocation without limits in opencast from opencast. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.9%top 39.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Opencast is free and open source software for automated video capture and distribution. First noticed in Opencast 13 and 14, Opencast's Elasticsearch integration may generate syntactically invalid Elasticsearch queries in relation to previously acceptable search queries. From Opencast version 11.4 and newer, Elasticsearch queries are retried a configurable number of times in the case of error to handle temporary losses of connection to Elasticsearch. These invalid queries would fail, causing the retry mechanism to begin requerying with the same syntactically invalid query immediately, in an infinite loop. This causes a massive increase in log size which can in some cases cause a denial of service due to disk exhaustion. Opencast 13.10 and Opencast 14.3 contain patches which address the base issue, with Opencast 16.7 containing changes which harmonize the search behaviour between the admin UI and external API. Users are strongly recommended to upgrade as soon as possible if running versions prior to 13.10 or 14.3. While the relevant endpoints require (by default) `ROLE_ADMIN` or `ROLE_API_SERIES_VIEW`, the problem queries are otherwise innocuous. This issue could be easily triggered by normal administrative work on an affected Opencast system. Those who run a version newer than 13.10 and 14.3 and see different results when searching in their admin UI vs your external API or LMS, may resolve the issue by upgrading to 16.7. No known workarounds for the vulnerability are available.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.opencastproject:opencast-elasticsearch-impl13.10GHSA-jh6x-7xfg-9cq2
Mavenorg.opencastproject:opencast-elasticsearch-impl14.3GHSA-jh6x-7xfg-9cq2
Mavenorg.opencastproject:opencast-elasticsearch-impl16.7GHSA-jh6x-7xfg-9cq2

Affected products (as reported)

VendorProductVersions
opencast opencast >= 11.4, < 13.10>= 14.0, < 14.3>= 15.0, < 16.7

Weakness: CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

References