Vulnerability · Published Apr 23, 2025 · Assigned by GitHub_M
CVE-2024-47829pnpm uses the md5 path shortening function causes packet paths to coincide, which causes indirect packet overwriting
Medium 6.5
In plain English
A medium-severity security flaw in pnpm from pnpm. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
pnpm is a package manager. Prior to version 10.0.0, the path shortening function uses the md5 function as a path shortening compression function, and if a collision occurs, it will result in the same storage path for two different libraries. Although the real names are under the package name /node_modoules/, there are no version numbers for the libraries they refer to. This issue has been patched in version 10.0.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | pnpm | 10.0.0 | GHSA-8cc4-rfj6-fhg4 |
Affected products (as reported)
Weakness: CWE-328 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:L
References
- https://github.com/pnpm/pnpm/security/advisories/GHSA-8cc4-rfj6-fhg4 x_refsource_CONFIRM