Vulnerability · Published Dec 11, 2024 · Assigned by GitHub_M

CVE-2024-47774GHSL-2024-262: GStreamer has an OOB-read in gst_avi_subtitle_parse_gab2_chunk

Medium 5.1

In plain English

A medium-severity out-of-bounds read in gstreamer from gstreamer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 58% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.1Medium
Exploit odds (30 days)0.8%top 42.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

GStreamer is a library for constructing graphs of media-handling components. An OOB-read vulnerability has been identified in the gst_avi_subtitle_parse_gab2_chunk function within gstavisubtitle.c. The function reads the name_length value directly from the input file without checking it properly. Then, the a condition, does not properly handle cases where name_length is greater than 0xFFFFFFFF - 17, causing an integer overflow. In such scenario, the function attempts to access memory beyond the buffer leading to an OOB-read. This vulnerability is fixed in 1.24.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:9gstreamer1-plugins-good1.22.12-4.el9ALSA-2025:7242
AlmaLinux:9gstreamer1-plugins-good-gtk1.22.12-4.el9ALSA-2025:7242
Alpine:v3.20gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47774
Alpine:v3.21gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47774
Alpine:v3.22gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47774
Alpine:v3.23gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47774
Alpine:v3.24gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47774
Debian:12gst-plugins-good1.01.22.0-5+deb12u2DSA-5838-1
Debian:12gst-plugins-good1.01.22.0-5+deb12u2DEBIAN-CVE-2024-47774
Debian:13gst-plugins-good1.01.24.10-1DEBIAN-CVE-2024-47774
Debian:14gst-plugins-good1.01.24.10-1DEBIAN-CVE-2024-47774
Rocky Linux:9gstreamer1-plugins-good0:1.22.12-4.el9RLSA-2025:7242
Ubuntu:22.04:LTSgst-plugins-good1.01.20.3-0ubuntu1.3USN-7176-1
Ubuntu:22.04:LTSgst-plugins-good1.01.20.3-0ubuntu1.3UBUNTU-CVE-2024-47774
Ubuntu:24.04:LTSgst-plugins-good1.01.24.2-1ubuntu1.1UBUNTU-CVE-2024-47774
Ubuntu:24.04:LTSgst-plugins-good1.01.24.2-1ubuntu1.1USN-7176-1

Affected products (as reported)

VendorProductVersions
gstreamer gstreamer < 1.24.10

Weakness: CWE-125 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N

References