Vulnerability · Published Dec 11, 2024 · Assigned by GitHub_M

CVE-2024-47606GHSL-2024-166: GStreamer Integer overflows in MP4/MOV demuxer and memory allocator that can lead to out-of-bounds writes

High 8.6

In plain English

A high-severity integer overflow in gstreamer from gstreamer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.7% (higher than 78% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.6High
Exploit odds (30 days)1.7%top 22.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

GStreamer is a library for constructing graphs of media-handling components. An integer underflow has been detected in the function qtdemux_parse_theora_extension within qtdemux.c. The vulnerability occurs due to an underflow of the gint size variable, which causes size to hold a large unintended value when cast to an unsigned integer. This 32-bit negative value is then cast to a 64-bit unsigned integer (0xfffffffffffffffa) in a subsequent call to gst_buffer_new_and_alloc. The function gst_buffer_new_allocate then attempts to allocate memory, eventually calling _sysmem_new_block. The function _sysmem_new_block adds alignment and header size to the (unsigned) size, causing the overflow of the 'slice_size' variable. As a result, only 0x89 bytes are allocated, despite the large input size. When the following memcpy call occurs in gst_buffer_fill, the data from the input file will overwrite the content of the GstMapInfo info structure. Finally, during the call to gst_memory_unmap, the overwritten memory may cause a function pointer hijack, as the mem->allocator->mem_unmap_full function is called with a corrupted pointer. This function pointer overwrite could allow an attacker to alter the execution flow of the program, leading to arbitrary code execution. This vulnerability is fixed in 1.24.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8gstreamer1-plugins-good1.16.1-5.el8_10ALSA-2024:11299
AlmaLinux:9gstreamer1-plugins-good1.22.1-3.el9_5ALSA-2024:11122
AlmaLinux:8gstreamer1-plugins-good-gtk1.16.1-5.el8_10ALSA-2024:11299
AlmaLinux:9gstreamer1-plugins-good-gtk1.22.1-3.el9_5ALSA-2024:11122
Alpine:v3.20gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47606
Alpine:v3.21gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47606
Alpine:v3.22gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47606
Alpine:v3.23gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47606
Alpine:v3.24gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47606
Debian:12gst-plugins-good1.01.22.0-5+deb12u2DSA-5838-1
Debian:12gst-plugins-good1.01.22.0-5+deb12u2DEBIAN-CVE-2024-47606
Debian:13gst-plugins-good1.01.24.10-1DEBIAN-CVE-2024-47606
Debian:14gst-plugins-good1.01.24.10-1DEBIAN-CVE-2024-47606
Debian:12gstreamer1.01.22.0-2+deb12u1DEBIAN-CVE-2024-47606
Debian:12gstreamer1.01.22.0-2+deb12u1DSA-5832-1
Debian:13gstreamer1.01.24.10-1DEBIAN-CVE-2024-47606
Debian:14gstreamer1.01.24.10-1DEBIAN-CVE-2024-47606
Rocky Linux:8gstreamer1-plugins-good0:1.16.1-5.el8_10RLSA-2024:11299
Rocky Linux:9gstreamer1-plugins-good0:1.22.1-3.el9_5RLSA-2024:11122
Ubuntu:22.04:LTSgst-plugins-good1.01.20.3-0ubuntu1.3USN-7176-1
Ubuntu:22.04:LTSgst-plugins-good1.01.20.3-0ubuntu1.3UBUNTU-CVE-2024-47606
Ubuntu:24.04:LTSgst-plugins-good1.01.24.2-1ubuntu1.1UBUNTU-CVE-2024-47606
Ubuntu:24.04:LTSgst-plugins-good1.01.24.2-1ubuntu1.1USN-7176-1
Ubuntu:22.04:LTSgstreamer1.01.20.3-0ubuntu1.1USN-7174-1
Ubuntu:22.04:LTSgstreamer1.01.20.3-0ubuntu1.1UBUNTU-CVE-2024-47606
Ubuntu:24.04:LTSgstreamer1.01.24.2-1ubuntu0.1USN-7174-1
Ubuntu:24.04:LTSgstreamer1.01.24.2-1ubuntu0.1UBUNTU-CVE-2024-47606

Affected products (as reported)

VendorProductVersions
gstreamer gstreamer < 1.24.10

Weakness: CWE-190 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References