Vulnerability · Published Dec 11, 2024 · Assigned by GitHub_M

CVE-2024-47600GHSL-2024-248: GStreamer has an OOB-read in format_channel_mask

Medium 5.1

In plain English

A medium-severity out-of-bounds read in gstreamer from gstreamer. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 67% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.1Medium
Exploit odds (30 days)1.1%top 33.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

GStreamer is a library for constructing graphs of media-handling components. An OOB-read vulnerability has been detected in the format_channel_mask function in gst-discoverer.c. The vulnerability affects the local array position, which is defined with a fixed size of 64 elements. However, the function gst_discoverer_audio_info_get_channels may return a guint channels value greater than 64. This causes the for loop to attempt access beyond the bounds of the position array, resulting in an OOB-read when an index greater than 63 is used. This vulnerability can result in reading unintended bytes from the stack. Additionally, the dereference of value->value_nick after the OOB-read can lead to further memory corruption or undefined behavior. This vulnerability is fixed in 1.24.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:9gstreamer1-plugins-base1.22.12-4.el9ALSA-2025:7243
AlmaLinux:9gstreamer1-plugins-base-devel1.22.12-4.el9ALSA-2025:7243
AlmaLinux:9gstreamer1-plugins-base-tools1.22.12-4.el9ALSA-2025:7243
Alpine:v3.20gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47600
Alpine:v3.21gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47600
Alpine:v3.22gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47600
Alpine:v3.23gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47600
Alpine:v3.24gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47600
Debian:12gst-plugins-base1.01.22.0-3+deb12u3DSA-5831-1
Debian:12gst-plugins-base1.01.22.0-3+deb12u3DEBIAN-CVE-2024-47600
Debian:13gst-plugins-base1.01.24.10-1DEBIAN-CVE-2024-47600
Debian:14gst-plugins-base1.01.24.10-1DEBIAN-CVE-2024-47600
Rocky Linux:9gstreamer1-plugins-base0:1.22.12-4.el9RLSA-2025:7243
Ubuntu:22.04:LTSgst-plugins-base1.01.20.1-1ubuntu0.4USN-7175-1
Ubuntu:22.04:LTSgst-plugins-base1.01.20.1-1ubuntu0.4UBUNTU-CVE-2024-47600
Ubuntu:24.04:LTSgst-plugins-base1.01.24.2-1ubuntu0.2UBUNTU-CVE-2024-47600
Ubuntu:24.04:LTSgst-plugins-base1.01.24.2-1ubuntu0.2USN-7175-1

Affected products (as reported)

VendorProductVersions
gstreamer gstreamer < 1.24.10

Weakness: CWE-125 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N

References