Vulnerability · Published Dec 11, 2024 · Assigned by GitHub_M

CVE-2024-47541GHSL-2024-228: GStreamer has an out-of-bounds write in SSA subtitle parser

Medium 6.9

In plain English

A medium-severity out-of-bounds write in gstreamer from gstreamer. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 71% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)1.3%top 28.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

GStreamer is a library for constructing graphs of media-handling components. An OOB-write vulnerability has been identified in the gst_ssa_parse_remove_override_codes function of the gstssaparse.c file. This function is responsible for parsing and removing SSA (SubStation Alpha) style override codes, which are enclosed in curly brackets ({}). The issue arises when a closing curly bracket "}" appears before an opening curly bracket "{" in the input string. In this case, memmove() incorrectly duplicates a substring. With each successive loop iteration, the size passed to memmove() becomes progressively larger (strlen(end+1)), leading to a write beyond the allocated memory bounds. This vulnerability is fixed in 1.24.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:9gstreamer1-plugins-base1.22.12-4.el9ALSA-2025:7243
AlmaLinux:9gstreamer1-plugins-base-devel1.22.12-4.el9ALSA-2025:7243
AlmaLinux:9gstreamer1-plugins-base-tools1.22.12-4.el9ALSA-2025:7243
Alpine:v3.20gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47541
Alpine:v3.21gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47541
Alpine:v3.22gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47541
Alpine:v3.23gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47541
Alpine:v3.24gst-plugins-base1.24.10-r0ALPINE-CVE-2024-47541
Debian:12gst-plugins-base1.01.22.0-3+deb12u3DSA-5831-1
Debian:12gst-plugins-base1.01.22.0-3+deb12u3DEBIAN-CVE-2024-47541
Debian:13gst-plugins-base1.01.24.10-1DEBIAN-CVE-2024-47541
Debian:14gst-plugins-base1.01.24.10-1DEBIAN-CVE-2024-47541
Rocky Linux:9gstreamer1-plugins-base0:1.22.12-4.el9RLSA-2025:7243
Ubuntu:22.04:LTSgst-plugins-base1.01.20.1-1ubuntu0.4USN-7175-1
Ubuntu:22.04:LTSgst-plugins-base1.01.20.1-1ubuntu0.4UBUNTU-CVE-2024-47541
Ubuntu:24.04:LTSgst-plugins-base1.01.24.2-1ubuntu0.2UBUNTU-CVE-2024-47541
Ubuntu:24.04:LTSgst-plugins-base1.01.24.2-1ubuntu0.2USN-7175-1

Affected products (as reported)

VendorProductVersions
gstreamer gstreamer < 1.24.10

Weakness: CWE-787 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References