Vulnerability · Published Dec 11, 2024 · Assigned by GitHub_M

CVE-2024-47540GHSL-2024-197: GStreamer uses uninitialized stack memory in Matroska/WebM demuxer

High 8.6

In plain English

A high-severity security flaw in gstreamer from gstreamer. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.6High
Exploit odds (30 days)1.0%top 36.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

GStreamer is a library for constructing graphs of media-handling components. An uninitialized stack variable vulnerability has been identified in the gst_matroska_demux_add_wvpk_header function within matroska-demux.c. When size < 4, the program calls gst_buffer_unmap with an uninitialized map variable. Then, in the gst_memory_unmap function, the program will attempt to unmap the buffer using the uninitialized map variable, causing a function pointer hijack, as it will jump to mem->allocator->mem_unmap_full or mem->allocator->mem_unmap. This vulnerability could allow an attacker to hijack the execution flow, potentially leading to code execution. This vulnerability is fixed in 1.24.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8gstreamer1-plugins-good1.16.1-5.el8_10ALSA-2024:11299
AlmaLinux:9gstreamer1-plugins-good1.22.1-3.el9_5ALSA-2024:11122
AlmaLinux:8gstreamer1-plugins-good-gtk1.16.1-5.el8_10ALSA-2024:11299
AlmaLinux:9gstreamer1-plugins-good-gtk1.22.1-3.el9_5ALSA-2024:11122
Alpine:v3.20gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47540
Alpine:v3.21gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47540
Alpine:v3.22gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47540
Alpine:v3.23gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47540
Alpine:v3.24gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47540
Debian:12gst-plugins-good1.01.22.0-5+deb12u2DSA-5838-1
Debian:12gst-plugins-good1.01.22.0-5+deb12u2DEBIAN-CVE-2024-47540
Debian:13gst-plugins-good1.01.24.10-1DEBIAN-CVE-2024-47540
Debian:14gst-plugins-good1.01.24.10-1DEBIAN-CVE-2024-47540
Rocky Linux:8gstreamer1-plugins-good0:1.16.1-5.el8_10RLSA-2024:11299
Rocky Linux:9gstreamer1-plugins-good0:1.22.1-3.el9_5RLSA-2024:11122
Ubuntu:22.04:LTSgst-plugins-good1.01.20.3-0ubuntu1.3USN-7176-1
Ubuntu:22.04:LTSgst-plugins-good1.01.20.3-0ubuntu1.3UBUNTU-CVE-2024-47540
Ubuntu:24.04:LTSgst-plugins-good1.01.24.2-1ubuntu1.1UBUNTU-CVE-2024-47540
Ubuntu:24.04:LTSgst-plugins-good1.01.24.2-1ubuntu1.1USN-7176-1

Affected products (as reported)

VendorProductVersions
gstreamer gstreamer < 1.24.10

Weakness: CWE-457 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References