Vulnerability · Published Dec 11, 2024 · Assigned by GitHub_M

CVE-2024-47539GHSL-2024-195: GStreamer has an OOB-write in convert_to_s334_1a

High 8.6

In plain English

A high-severity out-of-bounds write in gstreamer from gstreamer. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 71% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.6High
Exploit odds (30 days)1.3%top 28.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

GStreamer is a library for constructing graphs of media-handling components. An out-of-bounds write vulnerability was identified in the convert_to_s334_1a function in isomp4/qtdemux.c. The vulnerability arises due to a discrepancy between the size of memory allocated to the storage array and the loop condition i * 2 < ccpair_size. Specifically, when ccpair_size is even, the allocated size in storage does not match the loop's expected bounds, resulting in an out-of-bounds write. This bug allows for the overwriting of up to 3 bytes beyond the allocated bounds of the storage array. This vulnerability is fixed in 1.24.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8gstreamer1-plugins-good1.16.1-5.el8_10ALSA-2024:11299
AlmaLinux:9gstreamer1-plugins-good1.22.1-3.el9_5ALSA-2024:11122
AlmaLinux:8gstreamer1-plugins-good-gtk1.16.1-5.el8_10ALSA-2024:11299
AlmaLinux:9gstreamer1-plugins-good-gtk1.22.1-3.el9_5ALSA-2024:11122
Alpine:v3.20gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47539
Alpine:v3.21gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47539
Alpine:v3.22gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47539
Alpine:v3.23gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47539
Alpine:v3.24gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47539
Debian:12gst-plugins-good1.01.22.0-5+deb12u2DSA-5838-1
Debian:12gst-plugins-good1.01.22.0-5+deb12u2DEBIAN-CVE-2024-47539
Debian:13gst-plugins-good1.01.24.10-1DEBIAN-CVE-2024-47539
Debian:14gst-plugins-good1.01.24.10-1DEBIAN-CVE-2024-47539
Rocky Linux:8gstreamer1-plugins-good0:1.16.1-5.el8_10RLSA-2024:11299
Rocky Linux:9gstreamer1-plugins-good0:1.22.1-3.el9_5RLSA-2024:11122
Ubuntu:22.04:LTSgst-plugins-good1.01.20.3-0ubuntu1.3USN-7176-1
Ubuntu:22.04:LTSgst-plugins-good1.01.20.3-0ubuntu1.3UBUNTU-CVE-2024-47539
Ubuntu:24.04:LTSgst-plugins-good1.01.24.2-1ubuntu1.1UBUNTU-CVE-2024-47539
Ubuntu:24.04:LTSgst-plugins-good1.01.24.2-1ubuntu1.1USN-7176-1

Affected products (as reported)

VendorProductVersions
gstreamer gstreamer < 1.24.10

Weakness: CWE-787 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References