Vulnerability · Published Dec 11, 2024 · Assigned by GitHub_M

CVE-2024-47537GHSL-2024-094: GStreamer has an OOB-write in isomp4/qtdemux.c

High 8.6

In plain English

A high-severity out-of-bounds write in gstreamer from gstreamer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.6High
Exploit odds (30 days)1.0%top 38.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

GStreamer is a library for constructing graphs of media-handling components. The program attempts to reallocate the memory pointed to by stream->samples to accommodate stream->n_samples + samples_count elements of type QtDemuxSample. The problem is that samples_count is read from the input file. And if this value is big enough, this can lead to an integer overflow during the addition. As a consequence, g_try_renew might allocate memory for a significantly smaller number of elements than intended. Following this, the program iterates through samples_count elements and attempts to write samples_count number of elements, potentially exceeding the actual allocated memory size and causing an OOB-write. This vulnerability is fixed in 1.24.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8gstreamer1-plugins-good1.16.1-5.el8_10ALSA-2024:11299
AlmaLinux:9gstreamer1-plugins-good1.22.1-3.el9_5ALSA-2024:11122
AlmaLinux:8gstreamer1-plugins-good-gtk1.16.1-5.el8_10ALSA-2024:11299
AlmaLinux:9gstreamer1-plugins-good-gtk1.22.1-3.el9_5ALSA-2024:11122
Alpine:v3.20gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47537
Alpine:v3.21gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47537
Alpine:v3.22gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47537
Alpine:v3.23gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47537
Alpine:v3.24gst-plugins-good1.24.10-r0ALPINE-CVE-2024-47537
Debian:12gst-plugins-good1.01.22.0-5+deb12u2DSA-5838-1
Debian:12gst-plugins-good1.01.22.0-5+deb12u2DEBIAN-CVE-2024-47537
Debian:13gst-plugins-good1.01.24.10-1DEBIAN-CVE-2024-47537
Debian:14gst-plugins-good1.01.24.10-1DEBIAN-CVE-2024-47537
Rocky Linux:8gstreamer1-plugins-good0:1.16.1-5.el8_10RLSA-2024:11299
Rocky Linux:9gstreamer1-plugins-good0:1.22.1-3.el9_5RLSA-2024:11122
Ubuntu:22.04:LTSgst-plugins-good1.01.20.3-0ubuntu1.3USN-7176-1
Ubuntu:22.04:LTSgst-plugins-good1.01.20.3-0ubuntu1.3UBUNTU-CVE-2024-47537
Ubuntu:24.04:LTSgst-plugins-good1.01.24.2-1ubuntu1.1UBUNTU-CVE-2024-47537
Ubuntu:24.04:LTSgst-plugins-good1.01.24.2-1ubuntu1.1USN-7176-1

Affected products (as reported)

VendorProductVersions
gstreamer gstreamer < 1.24.10

Weakness: CWE-787, CWE-190 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References