Vulnerability · Published Oct 1, 2024 · Assigned by GitHub_M

CVE-2024-47525Stored XSS ('Cross-site Scripting') in librenms/includes/html/print-alert-rules.php

High 7.5

In plain English

A high-severity cross-site scripting in librenms from librenms. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 29.6% (higher than 98% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)29.6%top 1.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. A Stored Cross-Site Scripting (XSS) vulnerability in the "Alert Rules" feature allows authenticated users to inject arbitrary JavaScript through the "Title" field. This vulnerability can lead to the execution of malicious code in the context of other users' sessions, potentially compromising their accounts and allowing unauthorized actions. This vulnerability is fixed in 24.9.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistlibrenms/librenms24.9.0GHSA-j2j9-7pr6-xqwv

Affected products (as reported)

VendorProductVersions
librenms librenms < 24.9.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:L

References