Vulnerability · Published Nov 26, 2024 · Assigned by apache

CVE-2024-47249Apache NimBLE: Lack of input sanitization leading to out-of-bound reads in multiple advertisement handler

Medium 5.0

In plain English

A medium-severity security flaw in Apache NimBLE from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities).

Severity (CVSS 3.1)5.0Medium
Exploit odds (30 days)0.6%top 50.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Validation of Array Index vulnerability in Apache NimBLE. Lack of input validation for HCI events from controller could result in out-of-bound memory corruption and crash. This issue requires broken or bogus Bluetooth controller and thus severity is considered low. This issue affects Apache NimBLE: through 1.7.0. Users are recommended to upgrade to version 1.8.0, which fixes the issue.

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache NimBLE 0 – through 1.7.0

Weakness: CWE-129 · Vector: CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

References