Vulnerability · Published Sep 30, 2024 · Assigned by apache

CVE-2024-45772Apache Lucene Replicator: Security Vulnerability in Lucene Replicator - Deserialization Issue

Medium 5.1

In plain English

A medium-severity unsafe deserialization in Apache Lucene Replicator from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.1Medium
Exploit odds (30 days)0.6%top 52.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Deserialization of Untrusted Data vulnerability in Apache Lucene Replicator. This issue affects Apache Lucene's replicator module: from 4.4.0 before 9.12.0. The deprecated org.apache.lucene.replicator.http package is affected. The org.apache.lucene.replicator.nrt package is not affected. Users are recommended to upgrade to version 9.12.0, which fixes the issue. The deserialization can only be triggered if users actively deploy an network-accessible implementation and a corresponding client using a HTTP library that uses the API (e.g., a custom servlet and HTTPClient). Java serialization filters (such as -Djdk.serialFilter='!*' on the commandline) can mitigate the issue on vulnerable versions without impacting functionality.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.lucene:lucene-replicator9.12.0GHSA-g643-xq6w-r67c

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Lucene Replicator 4.4.0 – before 9.12.0

Weakness: CWE-502 · Vector: CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:L

References