Vulnerability · Published Jan 21, 2025 · Assigned by apache

CVE-2024-45478Apache Ranger: Stored XSS in Edit Service page - Add logic to validate user input

Medium 4.8

In plain English

A medium-severity cross-site scripting in Apache Ranger from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.8Medium
Exploit odds (30 days)0.6%top 50.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Stored XSS vulnerability in Edit Service Page of Apache Ranger UI in Apache Ranger Version 2.4.0. Users are recommended to upgrade to version Apache Ranger 2.5.0, which fixes this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.ranger:ranger2.5.0GHSA-vrx2-mgr9-v67h

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Ranger 2.4.0 – before 2.5.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

References