Vulnerability · Published Sep 10, 2024 · Assigned by GitHub_M

CVE-2024-45409The Ruby SAML library vulnerable to a SAML authentication bypass via Incorrect XPath selector

Critical 10.0

In plain English

A critical-severity security flaw in ruby-saml from SAML-Toolkits. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 10.7% (higher than 96% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)10.0Critical
Exploit odds (30 days)10.7%top 4.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling1Public PoC

Official description

The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ruby-saml1.13.0-1+deb12u1DEBIAN-CVE-2024-45409
Debian:12ruby-saml1.13.0-1+deb12u1DSA-5774-1
RubyGemsruby-saml1.12.3GHSA-jw9c-mfg7-9rx2
RubyGemsruby-saml1.17.0GHSA-jw9c-mfg7-9rx2
Ubuntu:22.04:LTSruby-saml1.13.0-1ubuntu0.1USN-7309-1
Ubuntu:22.04:LTSruby-saml1.13.0-1ubuntu0.1UBUNTU-CVE-2024-45409
Ubuntu:24.04:LTSruby-saml1.15.0-1ubuntu0.24.04.1UBUNTU-CVE-2024-45409
Ubuntu:24.04:LTSruby-saml1.15.0-1ubuntu0.24.04.1USN-7309-1

Affected products (as reported)

VendorProductVersions
SAML-Toolkits ruby-saml < 1.12.3>= 1.13.0, < 1.17.0

Weakness: CWE-347 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N

References