Vulnerability · Published Sep 6, 2024 · Assigned by mitre

CVE-2024-44082

Medium 4.3

In plain English

A medium-severity missing authorization in the ironic package (Debian). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.5%top 54.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

In OpenStack Ironic before 26.0.1 and ironic-python-agent before 9.13.1, there is a vulnerability in image processing, in which a crafted image could be used by an authenticated user to exploit undesired behaviors in qemu-img, including possible unauthorized access to potentially sensitive data. The affected/fixed version details are: Ironic: <21.4.3, >=22.0.0 <23.0.2, >=23.1.0 <24.1.2, >=25.0.0 <26.0.1; Ironic-python-agent: <9.4.2, >=9.5.0 <9.7.1, >=9.8.0 <9.11.1, >=9.12.0 <9.13.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ironic1:21.4.4-0+deb12u1DEBIAN-CVE-2024-44082
Debian:13ironic1:26.1.0-1DEBIAN-CVE-2024-44082
Debian:14ironic1:26.1.0-1DEBIAN-CVE-2024-44082
Debian:13ironic-python-agent9.14.0-1DEBIAN-CVE-2024-44082
Debian:14ironic-python-agent9.14.0-1DEBIAN-CVE-2024-44082
Ubuntu:22.04:LTSironic1:20.1.0-0ubuntu1.2USN-6989-1
Ubuntu:22.04:LTSironic1:20.1.0-0ubuntu1.2UBUNTU-CVE-2024-44082
Ubuntu:24.04:LTSironic1:24.1.1-0ubuntu1.2UBUNTU-CVE-2024-44082
Ubuntu:24.04:LTSironic1:24.1.1-0ubuntu1.2USN-6989-1
Ubuntu:25.10ironicno fix listedUBUNTU-CVE-2024-44082
Ubuntu:26.04:LTSironicno fix listedUBUNTU-CVE-2024-44082
Ubuntu:26.10ironicno fix listedUBUNTU-CVE-2024-44082
Ubuntu:24.04:LTSironic-python-agentno fix listedUBUNTU-CVE-2024-44082
Ubuntu:25.10ironic-python-agentno fix listedUBUNTU-CVE-2024-44082
Ubuntu:26.04:LTSironic-python-agentno fix listedUBUNTU-CVE-2024-44082
Ubuntu:26.10ironic-python-agentno fix listedUBUNTU-CVE-2024-44082

Affected products (as reported)

VendorProductVersions
n/a n/a n/a

Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

References