Vulnerability · Published Sep 10, 2024 · Assigned by GitHub_M
CVE-2024-43799send vulnerable to template injection that can lead to XSS
Medium 5.0
In plain English
A medium-severity cross-site scripting in send from pillarjs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)5.0Medium
Exploit odds (30 days)0.5%top 54.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Send is a library for streaming files from the file system as a http response. Send passes untrusted user input to SendStream.redirect() which executes untrusted code. This issue is patched in send 0.19.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-send | 0.18.0+~cs1.19.1-3+deb12u1 | DEBIAN-CVE-2024-43799 |
| Debian:13 | node-send | 1.1.0+~cs1.19.4-1 | DEBIAN-CVE-2024-43799 |
| Debian:14 | node-send | 1.1.0+~cs1.19.4-1 | DEBIAN-CVE-2024-43799 |
| Ubuntu:22.04:LTS | node-send | no fix listed | UBUNTU-CVE-2024-43799 |
| Ubuntu:24.04:LTS | node-send | no fix listed | UBUNTU-CVE-2024-43799 |
| npm | send | 0.19.0 | GHSA-m6fv-jmcg-4jfg |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L