Vulnerability · Published Sep 10, 2024 · Assigned by GitHub_M

CVE-2024-43796express vulnerable to XSS via response.redirect()

Medium 5.0

In plain English

A medium-severity cross-site scripting in express from expressjs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.0Medium
Exploit odds (30 days)0.5%top 57.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Express.js minimalist web framework for node. In express < 4.20.0, passing untrusted user input - even after sanitizing it - to response.redirect() may execute untrusted code. This issue is patched in express 4.20.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-expressno fix listedDEBIAN-CVE-2024-43796
Debian:13node-express4.21.0+~cs8.36.26-1DEBIAN-CVE-2024-43796
Debian:14node-express4.21.0+~cs8.36.26-1DEBIAN-CVE-2024-43796
npmexpress4.20.0GHSA-qw6h-vgh9-j6wx
npmexpress5.0.0GHSA-qw6h-vgh9-j6wx

Affected products (as reported)

VendorProductVersions
expressjs express < 4.20.0>= 5.0.0-alpha.1, < 5.0.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L

References