Vulnerability · Published Oct 31, 2024 · Assigned by apache

CVE-2024-43383Apache Lucene.Net.Replicator: Remote Code Execution in Lucene.Net.Replicator

High 8.0

In plain English

A high-severity unsafe deserialization in Apache Lucene.Net.Replicator from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.0High
Exploit odds (30 days)1.2%top 31.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Deserialization of Untrusted Data vulnerability in Apache Lucene.Net.Replicator. This issue affects Apache Lucene.NET's Replicator library: from 4.8.0-beta00005 through 4.8.0-beta00016. An attacker that can intercept traffic between a replication client and server, or control the target replication node URL, can provide a specially-crafted JSON response that is deserialized as an attacker-provided exception type. This can result in remote code execution or other potential unauthorized access. Users are recommended to upgrade to version 4.8.0-beta00017, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
NuGetlucene.net.replicator4.8.0-beta00017GHSA-2qw8-ppr5-m96c

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Lucene.Net.Replicator 4.8.0-beta00005 – through 4.8.0-beta00016

Weakness: CWE-502 · Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References