Vulnerability · Published Aug 15, 2024 · Assigned by GitHub_M
CVE-2024-43370gettext.js vulnerable to cross-site scripting (XSS)
High 7.2
In plain English
A high-severity cross-site scripting in gettext.js from guillaumepotier. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
gettext.js is a GNU gettext port for node and the browser. There is a cross-site scripting (XSS) injection if `.po` dictionary definition files are corrupted. This vulnerability has been patched in version 2.0.3. As a workaround, control the origin of the definition catalog to prevent the use of this flaw in the definition of plural forms.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | gettext.js | 0.7.0-2+deb11u1 | DEBIAN-CVE-2024-43370 |
| Debian:13 | gettext.js | 0.7.0-4 | DEBIAN-CVE-2024-43370 |
| Debian:14 | gettext.js | 0.7.0-4 | DEBIAN-CVE-2024-43370 |
| Ubuntu:22.04:LTS | gettext.js | no fix listed | UBUNTU-CVE-2024-43370 |
| Ubuntu:24.04:LTS | gettext.js | no fix listed | UBUNTU-CVE-2024-43370 |
| npm | gettext.js | 2.0.3 | GHSA-vwhg-jwr4-vxgg |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| guillaumepotier | gettext.js | < 2.0.3 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N