Vulnerability · Published Sep 3, 2025 · Assigned by apache

CVE-2024-43115Apache DolphinScheduler: Alert Script Attack

High 8.8

In plain English

A high-severity improper input validation in Apache DolphinScheduler from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.6%top 51.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can execute any shell script server by alert script. This issue affects Apache DolphinScheduler: before 3.2.2. Users are recommended to upgrade to version 3.3.1, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.dolphinscheduler:dolphinscheduler3.2.2GHSA-3vcp-r62v-xpvg

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache DolphinScheduler 0 – before 3.2.2

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References