Vulnerability · Published Aug 14, 2024 · Assigned by GitHub_M
CVE-2024-42360Command Injection in sequenceserver
Critical 9.8
In plain English
A critical-severity command injection in sequenceserver from wurmlab. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
SequenceServer lets you rapidly set up a BLAST+ server with an intuitive user interface for personal or group use. Several HTTP endpoints did not properly sanitize user input and/or query parameters. This could be exploited to inject and run unwanted shell commands. This vulnerability has been fixed in 3.1.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| RubyGems | sequenceserver | 3.1.2 | GHSA-qv32-5wm2-p32h |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| wurmlab | sequenceserver | < 3.1.2 |
Weakness: CWE-77 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H