Vulnerability · Published Aug 8, 2024 · Assigned by GitHub_M

CVE-2024-42356Shopware vulnerable to Server Side Template Injection in Twig using Context functions

High 8.3

In plain English

A high-severity security flaw in shopware from shopware. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.3High
Exploit odds (30 days)0.6%top 48.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Shopware is an open commerce platform. Prior to versions 6.6.5.1 and 6.5.8.13, the `context` variable is injected into almost any Twig Template and allows to access to current language, currency information. The context object allows also to switch for a short time the scope of the Context as a helper with a callable function. The function can be called also from Twig and as the second parameter allows any callable, it's possible to call from Twig any statically callable PHP function/method. It's not possible as customer to provide any Twig code, the attacker would require access to Administration to exploit it using Mail templates or using App Scripts. Update to Shopware 6.6.5.1 or 6.5.8.13 to receive a patch. For older versions of 6.1, 6.2, 6.3 and 6.4 corresponding security measures are also available via a plugin.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistshopware/core6.5.8.13GHSA-35jp-8cgg-p4wj
Packagistshopware/core6.6.5.1GHSA-35jp-8cgg-p4wj
Packagistshopware/platform6.5.8.13GHSA-35jp-8cgg-p4wj
Packagistshopware/platform6.6.5.1GHSA-35jp-8cgg-p4wj

Affected products (as reported)

VendorProductVersions
shopware shopware <= 6.5.8.12>= 6.6.0.0, <= 6.6.5.0

Weakness: CWE-1336 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L

References