Vulnerability · Published Mar 17, 2025 · Assigned by GitHub_M

CVE-2024-40635containerd has an integer overflow in User ID handling

Medium 4.6

In plain English

A medium-severity integer overflow in containerd from containerd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.6Medium
Exploit odds (30 days)0.3%top 76.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

containerd is an open-source container runtime. A bug was found in containerd prior to versions 1.6.38, 1.7.27, and 2.0.4 where containers launched with a User set as a `UID:GID` larger than the maximum 32-bit signed integer can cause an overflow condition where the container ultimately runs as root (UID 0). This could cause unexpected behavior for environments that require containers to run as a non-root user. This bug has been fixed in containerd 1.6.38, 1.7.27, and 2.04. As a workaround, ensure that only trusted images are used and that only trusted users have permissions to import images.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12containerd1.6.20~ds1-1+deb12u2DEBIAN-CVE-2024-40635
Debian:13containerd1.7.24~ds1-6DEBIAN-CVE-2024-40635
Debian:14containerd1.7.24~ds1-6DEBIAN-CVE-2024-40635
Gogithub.com/containerd/containerd1.7.27GHSA-265r-hfxg-fhmg
Gogithub.com/containerd/containerd1.6.38GHSA-265r-hfxg-fhmg
Gogithub.com/containerd/containerd1.6.38, 1.7.27GO-2025-3528
Gogithub.com/containerd/containerd/v22.0.4GHSA-265r-hfxg-fhmg
Gogithub.com/containerd/containerd/v22.0.4GO-2025-3528
Ubuntu:22.04:LTScontainerd1.6.12-0ubuntu1~22.04.8USN-7374-1
Ubuntu:22.04:LTScontainerd1.6.12-0ubuntu1~22.04.8UBUNTU-CVE-2024-40635
Ubuntu:22.04:LTScontainerd-app1.7.24-0ubuntu1~22.04.2USN-7374-1
Ubuntu:22.04:LTScontainerd-app1.7.24-0ubuntu1~22.04.2UBUNTU-CVE-2024-40635
Ubuntu:24.04:LTScontainerd-app1.7.24-0ubuntu1~24.04.2UBUNTU-CVE-2024-40635
Ubuntu:24.04:LTScontainerd-app1.7.24-0ubuntu1~24.04.2USN-7374-1
Ubuntu:25.10containerd-app2.0.2-0ubuntu2UBUNTU-CVE-2024-40635

Affected products (as reported)

VendorProductVersions
containerd containerd < 1.6.38>= 1.7.0-beta.0, < 1.7.27>= 2.0.0-beta.0, < 2.0.4

Weakness: CWE-190 · Vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N

References