Vulnerability · Published Jul 17, 2024 · Assigned by apache
CVE-2024-39877Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler
High 8.8
In plain English
A high-severity code injection in Apache Airflow from Apache Software Foundation. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.7% (higher than 78% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | apache-airflow | 2.9.3 | GHSA-g5hv-r743-v8pm |
| PyPI | apache-airflow | 2.9.3 | PYSEC-2024-190 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Airflow | 2.4.0 – before 2.9.3 |
Weakness: CWE-94, CWE-277 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H