Vulnerability · Published Apr 18, 2024 · Assigned by VulDB
CVE-2024-3932Totara LMS User Selector cross-site request forgery
Low 3.1
In plain English
A low-severity cross-site request forgery in LMS from Totara. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities).
Official description
A vulnerability classified as problematic has been found in Totara LMS up to 18.7. This affects an unknown part of the component User Selector. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 13.46, 14.38, 15.33, 16.27, 17.21 and 18.8 is able to address this issue. It is recommended to upgrade the affected component.
Affected products (as reported)
Weakness: CWE-352, CWE-862 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N/E:P/RL:O/RC:C
References
- VDB-261369 | Totara LMS User Selector cross-site request forgery vdb-entry, technical-description
- VDB-261369 | CTI Indicators (IOB, IOC) signature, permissions-required
- Submit #314381 | Totara Totara LMS Totara 18.0.1 (Build: 20231128.01) Privileges Scalation third-party-advisory
- https://totara.community/mod/forum/discuss.php?d=27644 related