Vulnerability · Published Jun 7, 2024 · Assigned by GitHub_M

CVE-2024-37162zsa Generates Error Messages Containing Sensitive Information

Medium 4.0

In plain English

A medium-severity security flaw in zsa from IdoPesok. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.0Medium
Exploit odds (30 days)0.3%top 78.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

zsa is a library for building typesafe server actions in Next.js. All users are impacted. The zsa application transfers the parse error stack from the server to the client in production build mode. This can potentially reveal sensitive information about the server environment, such as the machine username and directory paths. An attacker could exploit this vulnerability to gain unauthorized access to sensitive server information. This information could be used to plan further attacks or gain a deeper understanding of the server infrastructure. This has been patched on `0.3.3`.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmzsa0.3.3GHSA-wjmj-h3xc-hxp8

Affected products (as reported)

VendorProductVersions
IdoPesok zsa < 0.3.3

Weakness: CWE-209 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

References