Vulnerability · Published Jul 3, 2024 · Assigned by GitHub_M
CVE-2024-37157Discourse vulnerable to Server-Side Request Forgery via FastImage
Medium 6.4
In plain English
A medium-severity server-side request forgery in discourse from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities).
Official description
Discourse is an open-source discussion platform. Prior to version 3.2.3 on the `stable` branch and version 3.3.0.beta4 on the `beta` and `tests-passed` branches, a malicious actor could get the FastImage library to redirect requests to an internal Discourse IP. This issue is patched in version 3.2.3 on the `stable` branch and version 3.3.0.beta4 on the `beta` and `tests-passed` branches. No known workarounds are available.
Affected products (as reported)
Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:L
References
- https://github.com/discourse/discourse/security/advisories/GHSA-46pq-7958-fc68 x_refsource_CONFIRM
- https://github.com/discourse/discourse/commit/5b8cf11b69e05d5c058c1148ec69ec309491fa6e x_refsource_MISC
- https://github.com/discourse/discourse/commit/67e78086035cec494b15ce79342a0cb9052c2d95 x_refsource_MISC