Vulnerability · Published May 30, 2024 · Assigned by GitHub_M
CVE-2024-35228Improper Handling of Insufficient Permissions in Wagtail
Medium 5.5
In plain English
A medium-severity security flaw in wagtail from wagtail. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Wagtail is an open source content management system built on Django. Due to an improperly applied permission check in the `wagtail.contrib.settings` module, a user with access to the Wagtail admin and knowledge of the URL of the edit view for a settings model can access and update that setting, even when they have not been granted permission over the model. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patched versions have been released as Wagtail 6.0.5 and 6.1.2. Wagtail releases prior to 6.0 are unaffected. Users are advised to upgrade. Site owners who are unable to upgrade to a patched version can avoid the vulnerability in `ModelViewSet` by registering the model as a snippet instead. No workaround is available for `wagtail.contrib.settings`.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | wagtail | 6.0.5 | GHSA-xxfm-vmcf-g33f |
| PyPI | wagtail | 6.1.2 | GHSA-xxfm-vmcf-g33f |
| PyPI | wagtail | 6.0.5, 6.1.2 | PYSEC-2026-2032 |
Affected products (as reported)
Weakness: CWE-280 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:N