Vulnerability · Published Jul 2, 2025 · Assigned by apache
CVE-2024-35164Apache Guacamole: Improper input validation of console codes
Medium 6.8
In plain English
A medium-severity security flaw in Apache Guacamole from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.6.0, which fixes this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.23 | guacamole-server | 1.6.0-r0 | ALPINE-CVE-2024-35164 |
| Alpine:v3.24 | guacamole-server | 1.6.0-r0 | ALPINE-CVE-2024-35164 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Guacamole | 0.8.0 – through 1.5.5 |
Weakness: CWE-129 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N