Vulnerability · Published May 7, 2024 · Assigned by GitHub_M

CVE-2024-34341The Trix Editor Contains an Arbitrary Code Execution Vulnerability

Medium 5.4

In plain English

A medium-severity cross-site scripting in trix from basecamp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.8%top 43.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Trix is a rich text editor. The Trix editor, versions prior to 2.1.1, is vulnerable to arbitrary code execution when copying and pasting content from the web or other documents with markup into the editor. The vulnerability stems from improper sanitization of pasted content, allowing an attacker to embed malicious scripts which are executed within the context of the application. Users should upgrade to Trix editor version 2.1.1 or later, which incorporates proper sanitization of input from copied content.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsactiontext7.0.8.3GHSA-qjqp-xr96-cj99
RubyGemsactiontext7.1.3.3GHSA-qjqp-xr96-cj99
npmtrix2.1.1GHSA-qjqp-xr96-cj99
npmtrix1.3.2GHSA-qjqp-xr96-cj99

Affected products (as reported)

VendorProductVersions
basecamp trix < 2.1.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

References