Vulnerability · Published May 2, 2024 · Assigned by apache

CVE-2024-32638Apache APISIX: Forward-Auth Request Smuggling

Medium 6.3

In plain English

A medium-severity security flaw in Apache APISIX from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities).

Severity (CVSS 3.1)6.3Medium
Exploit odds (30 days)1.1%top 35.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Apache APISIX when using `forward-auth` plugin.This issue affects Apache APISIX: from 3.8.0, 3.9.0. Users are recommended to upgrade to version 3.8.1, 3.9.1 or higher, which fixes the issue.

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache APISIX 3.8.0 – through 3.9.0

Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

References