Vulnerability · Published Jul 10, 2024 · Assigned by GitHub_M

CVE-2024-32469Decidim has cross-site scripting (XSS) in the pagination

High 7.1

In plain English

A high-severity cross-site scripting in decidim from decidim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.1High
Exploit odds (30 days)0.4%top 63.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Decidim is a participatory democracy framework. The pagination feature used in searches and filters is subject to potential XSS attack through a malformed URL using the GET parameter `per_page`. This vulnerability is fixed in 0.27.6 and 0.28.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsdecidim0.27.6GHSA-7cx8-44pc-xv3q
RubyGemsdecidim0.28.1GHSA-7cx8-44pc-xv3q

Affected products (as reported)

VendorProductVersions
decidim decidim < 0.27.6>= 0.28.0.rc1, < 0.28.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N

References