Vulnerability · Published May 14, 2024 · Assigned by apache

CVE-2024-32077Apache Airflow: XSS vulnerability in Task Instance Log/Log Details

Medium 5.4

In plain English

A medium-severity cross-site scripting in Apache Airflow from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 75% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)1.6%top 24.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Apache Airflow version 2.9.0 has a vulnerability that allows an authenticated attacker to inject malicious data into the task instance logs.  Users are recommended to upgrade to version 2.9.1, which fixes this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-airflow2.9.1GHSA-52gm-qmg3-r4qp
PyPIapache-airflowno fix listedPYSEC-2024-264

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Airflow 2.9.0 – before 2.9.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

References