Vulnerability · Published Mar 29, 2024 · Assigned by GitHub_M
CVE-2024-30247Command Injection as root in NextCloudPi web panel
Critical 10.0
In plain English
A critical-severity OS command injection in nextcloudpi from nextcloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.1% (higher than 82% of all known vulnerabilities).
Official description
NextcloudPi is a ready to use image for Virtual Machines, Raspberry Pi, Odroid HC1, Rock64 and other boards. A command injection vulnerability in NextCloudPi allows command execution as the root user via the NextCloudPi web-panel. Due to a security misconfiguration this can be used by anyone with access to NextCloudPi web-panel, no authentication is required. It is recommended that the NextCloudPi is upgraded to 1.53.1.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextcloud | nextcloudpi | < 1.53.1 |
Weakness: CWE-78 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
References
- https://github.com/nextcloud/nextcloudpi/security/advisories/GHSA-m597-72v7-j982 x_refsource_CONFIRM