Vulnerability · Published Mar 29, 2024 · Assigned by GitHub_M

CVE-2024-29904CodeIgniter4 Language class DoS Vulnerability

High 7.5

In plain English

A high-severity infinite loop in CodeIgniter4 from codeigniter4. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.8%top 44.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

CodeIgniter is a PHP full-stack web framework A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server. Upgrade to v4.4.7 or later.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcodeigniter4/framework4.4.7GHSA-39fp-mqmm-gxj6

Affected products (as reported)

VendorProductVersions
codeigniter4 CodeIgniter4 < 4.4.7

Weakness: CWE-835 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References