Vulnerability · Published Mar 27, 2024 · Assigned by GitHub_M
CVE-2024-28233XSS in JupyterHub via Self-XSS leveraged by Cookie Tossing
High 8.1
In plain English
A high-severity cross-site scripting in jupyterhub from jupyterhub. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
JupyterHub is an open source multi-user server for Jupyter notebooks. By tricking a user into visiting a malicious subdomain, the attacker can achieve an XSS directly affecting the former's session. More precisely, in the context of JupyterHub, this XSS could achieve full access to JupyterHub API and user's single-user server. The affected configurations are single-origin JupyterHub deployments and JupyterHub deployments with user-controlled applications running on subdomains or peer subdomains of either the Hub or a single-user server. This vulnerability is fixed in 4.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | jupyterhub | no fix listed | DEBIAN-CVE-2024-28233 |
| Debian:13 | jupyterhub | 5.0.0+ds1-1 | DEBIAN-CVE-2024-28233 |
| Debian:14 | jupyterhub | 5.0.0+ds1-1 | DEBIAN-CVE-2024-28233 |
| PyPI | jupyterhub | 4.1.0 | GHSA-7r3h-4ph8-w38g |
| PyPI | jupyterhub | 4.1.0 | PYSEC-2026-1480 |
| Ubuntu:22.04:LTS | jupyterhub | no fix listed | UBUNTU-CVE-2024-28233 |
| Ubuntu:24.04:LTS | jupyterhub | no fix listed | UBUNTU-CVE-2024-28233 |
| Ubuntu:25.10 | jupyterhub | no fix listed | UBUNTU-CVE-2024-28233 |
| Ubuntu:26.04:LTS | jupyterhub | no fix listed | UBUNTU-CVE-2024-28233 |
| Ubuntu:26.10 | jupyterhub | no fix listed | UBUNTU-CVE-2024-28233 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jupyterhub | jupyterhub | < 4.1.0 |
Weakness: CWE-79, CWE-352, CWE-565 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N