Vulnerability · Published May 7, 2024 · Assigned by apache

CVE-2024-28148Apache Superset: Incorrect datasource authorization on explore REST API

Medium 4.3

In plain English

A medium-severity incorrect authorization in Apache Superset from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.7%top 46.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

An authenticated user could potentially access metadata for a datasource they are not authorized to view by submitting a targeted REST API request.This issue affects Apache Superset: before 3.1.2. Users are recommended to upgrade to version 3.1.2 or above, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-superset3.1.2GHSA-299q-3p96-5898
PyPIapache-superset3.1.2PYSEC-2026-1153

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Superset 0 – before 3.1.2

Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

References