Vulnerability · Published Feb 28, 2024 · Assigned by GitHub_M

CVE-2024-27285YARD's default template vulnerable to Cross-site Scripting in generated frames.html

Medium 5.4

In plain English

A medium-severity cross-site scripting in yard from lsegal. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)1.1%top 35.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

YARD is a Ruby Documentation tool. The "frames.html" file within the Yard Doc's generated documentation is vulnerable to Cross-Site Scripting (XSS) attacks due to inadequate sanitization of user input within the JavaScript segment of the "frames.erb" template file. This vulnerability is fixed in 0.9.36.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12yard0.9.28-2+deb12u2DEBIAN-CVE-2024-27285
Debian:12yard0.9.28-2+deb12u2DSA-5635-1
Debian:13yard0.9.36-1DEBIAN-CVE-2024-27285
Debian:14yard0.9.36-1DEBIAN-CVE-2024-27285
RubyGemsyard0.9.36GHSA-8mq4-9jjh-9xrc
Ubuntu:22.04:LTSyard0.9.26-1ubuntu0.1USN-6731-1
Ubuntu:22.04:LTSyard0.9.26-1ubuntu0.1UBUNTU-CVE-2024-27285

Affected products (as reported)

VendorProductVersions
lsegal yard < 0.9.36

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

References