Vulnerability · Published Jul 10, 2024 · Assigned by GitHub_M

CVE-2024-27095Decidim cross-site scripting (XSS) in the admin panel

Medium 5.4

In plain English

A medium-severity cross-site scripting in decidim from decidim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.3%top 72.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Decidim is a participatory democracy framework. The admin panel is subject to potential XSS attach in case the attacker manages to modify some records being uploaded to the server. This vulnerability is fixed in 0.27.6 and 0.28.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsdecidim-admin0.27.6GHSA-529p-jj47-w3m3
RubyGemsdecidim-admin0.28.1GHSA-529p-jj47-w3m3

Affected products (as reported)

VendorProductVersions
decidim decidim < 0.27.6>= 0.28.0.rc1, < 0.28.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:N/A:N

References