Vulnerability · Published Feb 14, 2024 · Assigned by GitHub_M

CVE-2024-25617Denial of Service in HTTP Header parser in squid proxy

Medium 5.3

In plain English

A medium-severity uncontrolled resource consumption in squid from squid-cache. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 88.1% (higher than 99.8% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)88.1%top 0.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Squid is an open source caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Due to a Collapse of Data into Unsafe Value bug ,Squid may be vulnerable to a Denial of Service attack against HTTP header parsing. This problem allows a remote client or a remote server to perform Denial of Service when sending oversized headers in HTTP messages. In versions of Squid prior to 6.5 this can be achieved if the request_header_max_size or reply_header_max_size settings are unchanged from the default. In Squid version 6.5 and later, the default setting of these parameters is safe. Squid will emit a critical warning in cache.log if the administrator is setting these parameters to unsafe values. Squid will not at this time prevent these settings from being changed to unsafe values. Users are advised to upgrade to version 6.5. There are no known workarounds for this vulnerability. This issue is also tracked as SQUID-2024:2

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8libecap1.0.1-2.module_el8.6.0+2741+01592ae8ALSA-2024:1375
AlmaLinux:8libecap1.0.1-2.module_el8.6.0+3048+383bc947ALSA-2024:1375
AlmaLinux:8libecap-devel1.0.1-2.module_el8.6.0+2741+01592ae8ALSA-2024:1375
AlmaLinux:8libecap-devel1.0.1-2.module_el8.6.0+3048+383bc947ALSA-2024:1375
AlmaLinux:8squid7:4.15-7.module_el8.9.0+3749+dbf371ed.10ALSA-2024:1375
AlmaLinux:9squid7:5.5-6.el9_3.8ALSA-2024:1376
Debian:12squid5.7-2+deb12u1DSA-5637-1
Debian:12squid5.7-2+deb12u1DEBIAN-CVE-2024-25617
Debian:13squid6.5-1DEBIAN-CVE-2024-25617
Debian:14squid6.5-1DEBIAN-CVE-2024-25617
Rocky Linux:8libecap0:1.0.1-2.module+el8.9.0+1437+df5ea8f0RLSA-2024:1375
Ubuntu:22.04:LTSsquid5.7-0ubuntu0.22.04.4USN-6728-1
Ubuntu:22.04:LTSsquid5.7-0ubuntu0.22.04.4UBUNTU-CVE-2024-25617
Ubuntu:24.04:LTSsquid6.5-1ubuntu1UBUNTU-CVE-2024-25617

Affected products (as reported)

VendorProductVersions
squid-cache squid < 6.5

Weakness: CWE-400, CWE-182 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

References