Vulnerability · Published Feb 28, 2024 · Assigned by apache
CVE-2024-24779Apache Superset: Improper data authorization when creating a new dataset
Medium 5.0
In plain English
A medium-severity incorrect authorization in Apache Superset from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Apache Superset with custom roles that include `can write on dataset` and without all data access permissions, allows for users to create virtual datasets to data they don't have access to. These users could then use those virtual datasets to get access to unauthorized data. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | apache-superset | 3.0.4 | GHSA-wr6g-9wcr-cmqj |
| PyPI | apache-superset | 3.1.1 | GHSA-wr6g-9wcr-cmqj |
| PyPI | apache-superset | 3.0.4, 3.1.1 | PYSEC-2026-1191 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Superset | 0 – before 3.0.43.1.0 – before 3.1.1 |
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N