Vulnerability · Published Mar 13, 2024 · Assigned by apache

CVE-2024-24549Apache Tomcat: HTTP/2 header handling DoS

High 7.5

In plain English

A high-severity improper input validation in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 23.1% (higher than 98% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)23.1%top 2.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8tomcat1:9.0.87-1.el8_10.1.alma.1ALSA-2024:3666
AlmaLinux:9tomcat1:9.0.87-1.el9_4.1ALSA-2024:3307
AlmaLinux:8tomcat-admin-webapps1:9.0.87-1.el8_10.1.alma.1ALSA-2024:3666
AlmaLinux:9tomcat-admin-webapps1:9.0.87-1.el9_4.1ALSA-2024:3307
AlmaLinux:8tomcat-docs-webapp1:9.0.87-1.el8_10.1.alma.1ALSA-2024:3666
AlmaLinux:9tomcat-docs-webapp1:9.0.87-1.el9_4.1ALSA-2024:3307
AlmaLinux:8tomcat-el-3.0-api1:9.0.87-1.el8_10.1.alma.1ALSA-2024:3666
AlmaLinux:9tomcat-el-3.0-api1:9.0.87-1.el9_4.1ALSA-2024:3307
AlmaLinux:8tomcat-jsp-2.3-api1:9.0.87-1.el8_10.1.alma.1ALSA-2024:3666
AlmaLinux:9tomcat-jsp-2.3-api1:9.0.87-1.el9_4.1ALSA-2024:3307
AlmaLinux:8tomcat-lib1:9.0.87-1.el8_10.1.alma.1ALSA-2024:3666
AlmaLinux:9tomcat-lib1:9.0.87-1.el9_4.1ALSA-2024:3307
AlmaLinux:8tomcat-servlet-4.0-api1:9.0.87-1.el8_10.1.alma.1ALSA-2024:3666
AlmaLinux:9tomcat-servlet-4.0-api1:9.0.87-1.el9_4.1ALSA-2024:3307
AlmaLinux:8tomcat-webapps1:9.0.87-1.el8_10.1.alma.1ALSA-2024:3666
AlmaLinux:9tomcat-webapps1:9.0.87-1.el9_4.1ALSA-2024:3307
Debian:12tomcat1010.1.6-1+deb12u2DEBIAN-CVE-2024-24549
Debian:12tomcat1010.1.6-1+deb12u2DSA-5665-1
Debian:13tomcat1010.1.20-1DEBIAN-CVE-2024-24549
Debian:14tomcat1010.1.20-1DEBIAN-CVE-2024-24549
Debian:12tomcat99.0.70-2DEBIAN-CVE-2024-24549
Debian:13tomcat99.0.70-2DEBIAN-CVE-2024-24549
Debian:14tomcat99.0.70-2DEBIAN-CVE-2024-24549
Mavenorg.apache.tomcat.embed:tomcat-embed-core9.0.86GHSA-7w75-32cg-r6g2
Mavenorg.apache.tomcat.embed:tomcat-embed-core10.1.19GHSA-7w75-32cg-r6g2
Mavenorg.apache.tomcat.embed:tomcat-embed-core11.0.0-M17GHSA-7w75-32cg-r6g2
Mavenorg.apache.tomcat.embed:tomcat-embed-core8.5.99GHSA-7w75-32cg-r6g2
Mavenorg.apache.tomcat:tomcat-coyote9.0.86GHSA-7w75-32cg-r6g2
Mavenorg.apache.tomcat:tomcat-coyote10.1.19GHSA-7w75-32cg-r6g2
Mavenorg.apache.tomcat:tomcat-coyote11.0.0-M17GHSA-7w75-32cg-r6g2
Mavenorg.apache.tomcat:tomcat-coyote8.5.99GHSA-7w75-32cg-r6g2
Rocky Linux:8tomcat1:9.0.87-1.el8_10.1RLSA-2024:3666
Rocky Linux:9tomcat1:9.0.87-1.el9_4.1RLSA-2024:3307
Ubuntu:25.10tomcat99.0.70-2ubuntu3UBUNTU-CVE-2024-24549

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.0-M1610.1.0-M1 – through 10.1.189.0.0-M1 – through 9.0.858.5.0 – through 8.5.98

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References