Vulnerability · Published Jan 30, 2024 · Assigned by GitHub_M

CVE-2024-23841XSS in @apollo/experimental-nextjs-app-support

High 8.2

In plain English

A high-severity security flaw in apollo-client-nextjs from apollographql. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.2High
Exploit odds (30 days)0.4%top 67.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

apollo-client-nextjs is the Apollo Client support for the Next.js App Router. The @apollo/experimental-apollo-client-nextjs NPM package is vulnerable to a cross-site scripting vulnerability. To exploit this vulnerability, an attacker would need to either inject malicious input (e.g. by redirecting a user to a specifically-crafted link) or arrange to have malicious input be returned by a GraphQL server (e.g. by persisting it in a database). To fix this issue, please update to version 0.7.0 or later.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@apollo/experimental-nextjs-app-support0.7.0GHSA-rv8p-rr2h-fgpg

Affected products (as reported)

VendorProductVersions
apollographql apollo-client-nextjs < 0.7.0

Weakness: CWE-80 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N

References