Vulnerability · Published Jan 29, 2024 · Assigned by GitHub_M

CVE-2024-23828Nginx-UI authenticated RCE through injecting into the application config via CRLF

High 8.8

In plain English

A high-severity injection in nginx-ui from 0xJacky. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)1.1%top 35.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Nginx-UI is a web interface to manage Nginx configurations. It is vulnerable to an authenticated arbitrary command execution via CRLF attack when changing the value of test_config_cmd or start_cmd. This vulnerability exists due to an incomplete fix for CVE-2024-22197 and CVE-2024-22198. This vulnerability has been patched in version 2.0.0.beta.12.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/0xJacky/Nginx-UI1.9.10-0.20240126104956-d70e37c8575eGHSA-qcjq-7f7v-pvc8
Gogithub.com/0xJacky/Nginx-UIno fix listedGO-2024-2480

Affected products (as reported)

VendorProductVersions
0xJacky nginx-ui < v2.0.0.beta.12

Weakness: CWE-74 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References