Vulnerability · Published Jan 31, 2024 · Assigned by GitHub_M

CVE-2024-23653BuildKit interactive containers API does not validate entitlements check

Critical 9.8

In plain English

A critical-severity incorrect authorization in buildkit from moby. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.4% (higher than 89% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.8Critical
Exploit odds (30 days)3.4%top 10.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

BuildKit is a toolkit for converting source code to build artifacts in an efficient, expressive and repeatable manner. In addition to running containers as build steps, BuildKit also provides APIs for running interactive containers based on built images. It was possible to use these APIs to ask BuildKit to run a container with elevated privileges. Normally, running such containers is only allowed if special `security.insecure` entitlement is enabled both by buildkitd configuration and allowed by the user initializing the build request. The issue has been fixed in v0.12.5 . Avoid using BuildKit frontends from untrusted sources.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20buildkit0.12.5-r0ALPINE-CVE-2024-23653
Alpine:v3.21buildkit0.12.5-r0ALPINE-CVE-2024-23653
Alpine:v3.22buildkit0.12.5-r0ALPINE-CVE-2024-23653
Alpine:v3.23buildkit0.12.5-r0ALPINE-CVE-2024-23653
Alpine:v3.24buildkit0.12.5-r0ALPINE-CVE-2024-23653
Alpine:v3.20docker25.0.2-r0ALPINE-CVE-2024-23653
Alpine:v3.21docker25.0.2-r0ALPINE-CVE-2024-23653
Alpine:v3.22docker25.0.2-r0ALPINE-CVE-2024-23653
Alpine:v3.23docker25.0.2-r0ALPINE-CVE-2024-23653
Alpine:v3.24docker25.0.2-r0ALPINE-CVE-2024-23653
Alpine:v3.20podman4.9.2-r0ALPINE-CVE-2024-23653
Alpine:v3.21podman4.9.2-r0ALPINE-CVE-2024-23653
Alpine:v3.22podman4.9.2-r0ALPINE-CVE-2024-23653
Alpine:v3.23podman4.9.2-r0ALPINE-CVE-2024-23653
Alpine:v3.24podman4.9.2-r0ALPINE-CVE-2024-23653
Alpine:v3.20singularity4.1.1-r0ALPINE-CVE-2024-23653
Alpine:v3.21singularity4.1.1-r0ALPINE-CVE-2024-23653
Alpine:v3.22singularity4.1.1-r0ALPINE-CVE-2024-23653
Alpine:v3.23singularity4.1.1-r0ALPINE-CVE-2024-23653
Alpine:v3.24singularity4.1.1-r0ALPINE-CVE-2024-23653
Gogithub.com/moby/buildkit0.12.5GHSA-wr6v-9f75-vh2g
Gogithub.com/moby/buildkit0.12.5GO-2024-2497
Ubuntu:22.04:LTSdocker.io-app27.5.1-0ubuntu3~22.04.2UBUNTU-CVE-2024-23653
Ubuntu:24.04:LTSdocker.io-app27.5.1-0ubuntu3~24.04.2UBUNTU-CVE-2024-23653

Affected products (as reported)

VendorProductVersions
moby buildkit < 0.12.5

Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References