Vulnerability · Published Jan 16, 2024 · Assigned by GitHub_M

CVE-2024-22407Broken Access Control order API in Shopware

Medium 4.9

In plain English

A medium-severity improper access control in shopware from shopware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.9Medium
Exploit odds (30 days)0.4%top 65.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Shopware is an open headless commerce platform. In the Shopware CMS, the state handler for orders fails to sufficiently verify user authorizations for actions that modify the payment, delivery, and/or order status. Due to this inadequate implementation, users lacking 'write' permissions for orders are still able to change the order state. This issue has been addressed and users are advised to update to Shopware 6.5.7.4. For older versions of 6.1, 6.2, 6.3 and 6.4 corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistshopware/core6.5.7.4GHSA-3867-jc5c-66qf
Packagistshopware/platform6.5.7.4GHSA-3867-jc5c-66qf

Affected products (as reported)

VendorProductVersions
shopware shopware < 6.5.7.4

Weakness: CWE-284 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N

References