Vulnerability · Published Jan 8, 2024 · Assigned by GitHub_M
CVE-2024-21647HTTP Request/Response Smuggling in puma
Medium 5.9
In plain English
A medium-severity security flaw in puma from puma. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Puma is a web server for Ruby/Rack applications built for parallelism. Prior to version 6.4.2, puma exhibited incorrect behavior when parsing chunked transfer encoding bodies in a way that allowed HTTP request smuggling. Fixed versions limits the size of chunk extensions. Without this limit, an attacker could cause unbounded resource (CPU, network bandwidth) consumption. This vulnerability has been fixed in versions 6.4.2 and 5.6.8.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | puma | 5.6.5-3+deb12u1 | DEBIAN-CVE-2024-21647 |
| Debian:13 | puma | 6.4.2-1 | DEBIAN-CVE-2024-21647 |
| Debian:14 | puma | 6.4.2-1 | DEBIAN-CVE-2024-21647 |
| RubyGems | puma | 6.4.2 | GHSA-c2f4-cvqm-65w2 |
| RubyGems | puma | 5.6.8 | GHSA-c2f4-cvqm-65w2 |
Affected products (as reported)
Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H