Vulnerability · Published Feb 14, 2024 · Assigned by GitHub_P
CVE-2024-1482Improper Authorization in GitHub Enterprise Server allowed unauthorized workflow execution
High 7.1
In plain English
A high-severity incorrect authorization in Enterprise Server from GitHub. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities).
Official description
An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed an attacker to create new branches in public repositories and run arbitrary GitHub Actions workflows with permissions from the GITHUB_TOKEN. To exploit this vulnerability, an attacker would need access to the Enterprise Server. This vulnerability affected all versions of GitHub Enterprise Server after 3.8 and prior to 3.12, and was fixed in versions 3.9.10, 3.10.7, 3.11.5. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| GitHub | Enterprise Server | 3.9.0 – before 3.9.93.10.0 – before 3.10.63.11.0 – before 3.11.4 |
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N